Delay responding to support emails due to AWS outage

Incident Report for Aiir

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 07:15 UTC

Identified

We're currently unable to respond to customer emails as quickly as we would like due to an upstream issue with our email communication service, which is affected by wide-ranging Amazon Web Services outages. We will endeavour to respond as soon as possible. Other services, including our off-air emergency line is unaffected.
Posted Oct 20, 2025 - 16:42 UTC
This incident affected: Customer communications & Support resources.