Thanks for bearing with us. Our work on Page Manager is complete, and we're just checking to make sure everything is working as expected before allowing access again. You should be able to use it again very soon.
Posted Aug 06, 2026 - 09:56 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 06, 2026 - 09:00 UTC
Scheduled
We will be carrying out some essential updates to Page Manager, which may take up to an hour to complete. During that time, you won't be able to create or edit website pages, but your site will remain available to users. Other areas of the platform, such as posting news, managing ads, and scheduling music logs, will not be affected.
Posted Aug 05, 2026 - 10:32 UTC
This scheduled maintenance affected: Aiir platform (on.aiir.com).