Thank you for your patience. Our work on Page Manager is complete, and we're continuing to monitor for any issues.
Posted Aug 06, 2026 - 10:40 UTC
Identified
We're continuing to work on Page Manager and getting everything running smoothly. You can create and edit pages, but we have identified an issue where the contents of some folders may not appear. We aim to have this resolved as quickly as possible. Sorry for any inconvenience this has caused.
Posted Aug 06, 2026 - 10:30 UTC
This incident affected: Aiir platform (on.aiir.com).